PDA

View Full Version : need new hubs or rebuild 'em?


thrillbilly
08-21-2009, 08:39 PM
91 f250, when you manually lock the hubs and put it in 4 anything and drive it, it seems to stay in 2wd and every 10 ft or so, "CLUNK!!!"

worn actuators on the hubs or somethin else, i dont know YET but any relative experiences???

fullsizebronco
08-21-2009, 11:22 PM
I would first get someone to see if that's the problem by putting it in 4x4 and then get someone to look underneath as you drive forward to make sure the shafts near the hubs are spinning if they are pull your hubs apart could just be old dry grease rust dirt keeping them from locking in

thrillbilly
08-22-2009, 01:41 AM
hmm will have to do just that tomoroooo and ill post an update sundayy.
wish it'd git workin by the newbie run :(

fullsizebronco
08-22-2009, 08:15 AM
If you want them working for the run I guess there is a way to open them up and lock them in that way

thrillbilly
08-22-2009, 09:20 AM
wouldnt know where to start :(

Ginger Snaps
08-22-2009, 09:45 AM
pull them apart clean them put them back together... get a haynes manual if you dont know how...

thrillbilly
08-22-2009, 09:56 AM
im fine with pullin em just didnt know how to open up and lock 'em.

gonna try to gitmdone by the run.

Ginger Snaps
08-22-2009, 09:56 AM
you turn the dial....

thrillbilly
08-22-2009, 10:05 AM
lmao no i mean what fullsizebronco was talkin about "open them up and lock them in that way"

thrillbilly
08-22-2009, 10:48 AM
so shafts dont spin when hubs are locked, wonder why it clunks then.
off 2 clean em out and see what happens

Ginger Snaps
08-22-2009, 11:56 AM
its not your hubs its something else....the shafts should spin...

thrillbilly
08-22-2009, 02:31 PM
yea. and the tcase will go into 4hi but not N or 4low. somethins fuckered along the line.

Reeseman
08-22-2009, 03:12 PM
is it auto or manual?

thrillbilly
08-22-2009, 03:49 PM
autooo

thrillbilly
08-22-2009, 05:34 PM
linkage?

thrillbilly
08-23-2009, 02:09 PM
well 1 problem is deffinately hubs haha was in 2.5 wheel drive last night...

reese know anyone with a set? the d44 style not d50

Bulldozer
09-09-2009, 10:44 AM
Hey try this first...
http://www.explorerforum.com/forums/showthread.php?t=201782

thrillbilly
09-09-2009, 10:03 PM
thx those are the auto hubs though which have a very different problem i think.

found a decent deal on the hubs so why not upgrade i figure.